You are browsing a tutorial guide for Octoparse's latest version. If you are running an older version of Octoparse, we strongly recommend you upgrade because it is faster, easier, and more robust! Download and upgrade here if you haven't already done so!

It can be frustrating when the task does not scrape anything after you have spent a long time building the workflow but ended up with an error:

no_data.png

In this article, we are going to show you some tips to troubleshoot your task when it stops shortly after you run it.

Tip: When the cloud extraction completes but no data is extracted, please refer to Why does the task get no data in the Cloud but work well when running in the local?


When the local extraction completes but no data is extracted, it may be due to the following reasons:

1) The webpage provided does not load completely or takes too long to open and even timeouts.

You can observe the local run window to see if the web page has been loaded well before the error message pops up.

Resolution:

  • Check your internet connection and make sure the webpage can be opened in a normal browser.

  • Increase the timeout for the Go to Web Page to ensure the webpage loads completely before it moves on to the next step.


2) The information to scrape does not load as soon as the page loads.

You can observe the local run window after the task runs to see if the information needed is loaded well on the web page.

Resolution:

  • Set up some wait time for the action following Go to Web Page or set up Wait until a designated element appears, so Octoparse will wait until the information is shown on the page.

2.png
  • Add some scrolls for the Go to Web Page.

Some information (especially images) can only be loaded when the page is scrolled down.

3.png

3) Not setting up AJAX for the Click Item or the AJAX timeout is too short

Some websites may use the AJAX technique for updating new content. If the timeout is not set up properly, Octoparse may jump to the next action quickly and not get the information required.

Resolution:

  • Try setting up AJAX load for Click Item or Click to Paginate

To learn more about AJAX, please check: Deal with AJAX

4.png

4) Loop Items cannot locate elements properly

If the Loop Item does not locate the elements, the scrape will be stopped when executing the Loop Item.

Resolution:

  • Items are selected properly. If not (the Loop Item shows "Cannot find any element"), you will need to rebuild the workflow and make sure everything is done correctly.

5.png
  • If rebuilding the Loop Item still doesn’t work out, you may need to modify the XPath for the Loop Item manually. See more about Customize element XPath.

Did this answer your question?